PPI-Tester v0.15 Perl 5 v5.10.1 x86_64-linux

Status
Pass
From
Serguei Trouchelle (STRO)
Dist
PPI-Tester v0.15
Platform
Perl 5 v5.10.1 x86_64-linux
Date
2011-07-28T04:35:20
ID
009867f0-b8d3-11e0-aabb-834be85b031d
This distribution has been tested as part of the CPAN Testers
project, supporting the Perl programming language.  See
http://wiki.cpantesters.org/ for more information or email
questions to cpan-testers-discuss@perl.org


--
Dear Adam Kennedy,

This is a computer-generated report for PPI-Tester-0.15
on perl 5.10.1, created by CPAN-Reporter-1.19_04.

Thank you for uploading your work to CPAN.  Congratulations!
All tests were successful.

Sections of this report:

    * Tester comments
    * Program output
    * Prerequisites
    * Environment and other context

------------------------------
TESTER COMMENTS
------------------------------

Additional comments from tester:

this report is from an automated smoke testing program
and was not reviewed by a human for accuracy

------------------------------
PROGRAM OUTPUT
------------------------------

Output from '/usr/bin/make test':

PERL_DL_NONLAZY=1 /home/trushel/perl/perl5101th/bin/perl "-MExtUtils::Command::MM" "-e" "test_harness(0, 'inc', 'blib/lib', 'blib/arch')" t/*.t
t/01_compile.t .. ok
t/97_meta.t ..... ok
t/98_pod.t ...... ok
t/99_pmv.t ...... skipped: Perl::MinimumVersion 1.20 not available for testing
All tests successful.
Files=4, Tests=7,  2 wallclock secs ( 0.03 usr  0.01 sys +  0.40 cusr  0.14 csys =  0.58 CPU)
Result: PASS

------------------------------
PREREQUISITES
------------------------------

Prerequisite modules loaded:

requires:

    Module              Need  Have  
    ------------------- ----- ------
    Devel::Dumpvar      0.04  1.06  
    ExtUtils::MakeMaker 6.42  6.58  
    File::Spec          0.80  3.33  
    PPI                 1.201 1.215 
    Test::More          0.47  0.98  
    Test::Script        1.02  1.07  
    Wx                  0.54  0.9901

build_requires:

    Module              Need  Have  
    ------------------- ----- ------
    ExtUtils::MakeMaker 0     6.58  

configure_requires:

    Module              Need  Have  
    ------------------- ----- ------
    ExtUtils::MakeMaker 6.42  6.58  


------------------------------
ENVIRONMENT AND OTHER CONTEXT
------------------------------

Environment variables:

    AUTOMATED_TESTING = 1
    LANG = en_US.UTF-8
    LANGUAGE = en
    LC_COLLATE = C
    LC_MONETARY = C
    LC_NUMERIC = C
    LC_TIME = C
    PATH = /usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin
    PERL5LIB = 
    PERL5OPT = 
    PERL5_CPANPLUS_IS_RUNNING = 10269
    PERL5_CPAN_IS_RUNNING = 10269
    PERL5_CPAN_IS_RUNNING_IN_RECURSION = 6249,10269
    PERL_CR_SMOKER_CURRENT = PPI-Tester-0.15
    PERL_EXTUTILS_AUTOINSTALL = --defaultdeps
    PERL_MM_USE_DEFAULT = 1
    SHELL = /bin/bash
    TERM = xterm

Perl special variables (and OS-specific diagnostics, for MSWin32):

    $^X = /home/trushel/perl/perl5101th/bin/perl
    $UID/$EUID = 138375 / 138375
    $GID = 5762 4 20 21 24 25 26 30 44 46 104 105 119 122 431 5762
    $EGID = 5762 4 20 21 24 25 26 30 44 46 104 105 119 122 431 5762

Perl module toolchain versions installed:

    Module              Have       
    ------------------- -----------
    CPAN                1.97_51    
    CPAN::Meta          2.110930001
    Cwd                 3.33       
    ExtUtils::CBuilder  0.280202   
    ExtUtils::Command   1.16       
    ExtUtils::Install   1.54       
    ExtUtils::MakeMaker 6.58       
    ExtUtils::Manifest  1.58       
    ExtUtils::ParseXS   2.2206     
    File::Spec          3.33       
    JSON                2.53       
    JSON::PP            2.27200    
    Module::Build       0.3800     
    Module::Signature   n/a        
    Parse::CPAN::Meta   1.4401     
    Test::Harness       3.23       
    Test::More          0.98       
    YAML                0.73       
    YAML::Syck          1.17       
    version             0.91       


--

Summary of my perl5 (revision 5 version 10 subversion 1) configuration:
   
  Platform:
    osname=linux, osvers=2.6.32-33-generic, archname=x86_64-linux-thread-multi
    uname='linux trushel-glaptop 2.6.32-33-generic #70-ubuntu smp thu jul 7 21:13:52 utc 2011 x86_64 gnulinux '
    config_args=''
    hint=recommended, useposix=true, d_sigaction=define
    useithreads=define, usemultiplicity=define
    useperlio=define, d_sfio=undef, uselargefiles=define, usesocks=undef
    use64bitint=define, use64bitall=define, uselongdouble=undef
    usemymalloc=n, bincompat5005=undef
  Compiler:
    cc='cc', ccflags ='-D_REENTRANT -D_GNU_SOURCE -fno-strict-aliasing -pipe -fstack-protector -I/usr/local/include -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64',
    optimize='-O2',
    cppflags='-D_REENTRANT -D_GNU_SOURCE -fno-strict-aliasing -pipe -fstack-protector -I/usr/local/include'
    ccversion='', gccversion='4.4.3', gccosandvers=''
    intsize=4, longsize=8, ptrsize=8, doublesize=8, byteorder=12345678
    d_longlong=define, longlongsize=8, d_longdbl=define, longdblsize=16
    ivtype='long', ivsize=8, nvtype='double', nvsize=8, Off_t='off_t', lseeksize=8
    alignbytes=8, prototype=define
  Linker and Libraries:
    ld='cc', ldflags =' -fstack-protector -L/usr/local/lib'
    libpth=/usr/local/lib /lib /usr/lib /lib64 /usr/lib64
    libs=-lnsl -ldb -ldl -lm -lcrypt -lutil -lpthread -lc
    perllibs=-lnsl -ldl -lm -lcrypt -lutil -lpthread -lc
    libc=/lib/libc-2.11.1.so, so=so, useshrplib=false, libperl=libperl.a
    gnulibc_version='2.11.1'
  Dynamic Linking:
    dlsrc=dl_dlopen.xs, dlext=so, d_dlsymun=undef, ccdlflags='-Wl,-E'
    cccdlflags='-fPIC', lddlflags='-shared -O2 -L/usr/local/lib -fstack-protector'


Characteristics of this binary (from libperl): 
  Compile-time options: MULTIPLICITY PERL_DONT_CREATE_GVSV
                        PERL_IMPLICIT_CONTEXT PERL_MALLOC_WRAP USE_64_BIT_ALL
                        USE_64_BIT_INT USE_ITHREADS USE_LARGE_FILES
                        USE_PERLIO USE_REENTRANT_API
  Built under linux
  Compiled at Jul 22 2011 04:11:41
  %ENV:
    PERL5LIB=""
    PERL5OPT=""
    PERL5_CPANPLUS_IS_RUNNING="10269"
    PERL5_CPAN_IS_RUNNING="10269"
    PERL5_CPAN_IS_RUNNING_IN_RECURSION="6249,10269"
    PERL_CR_SMOKER_CURRENT="PPI-Tester-0.15"
    PERL_EXTUTILS_AUTOINSTALL="--defaultdeps"
    PERL_MM_USE_DEFAULT="1"
  @INC:
    /home/trushel/perl/perl5101th/lib/5.10.1/x86_64-linux-thread-multi
    /home/trushel/perl/perl5101th/lib/5.10.1
    /home/trushel/perl/perl5101th/lib/site_perl/5.10.1/x86_64-linux-thread-multi
    /home/trushel/perl/perl5101th/lib/site_perl/5.10.1
    .