Net-API-Stripe vv1.0.6 Perl 5 v5.30.3 x86_64-linux-thread-multi

Status
Fail
From
Chris Williams (BINGOS)
Dist
Net-API-Stripe vv1.0.6
Platform
Perl 5 v5.30.3 x86_64-linux-thread-multi
Date
2020-06-03T15:22:17
ID
02804e94-a5ae-11ea-9066-e374b0ba08e8
This distribution has been tested as part of the CPAN Testers
project, supporting the Perl programming language.  See
http://wiki.cpantesters.org/ for more information or email
questions to cpan-testers-discuss@perl.org


--

Dear JDEGUEST,

This is a computer-generated error report created automatically by
CPANPLUS, version 0.9908. Testers personal comments may appear
at the end of this report.


Thank you for uploading your work to CPAN.  However, it appears that
there were some problems testing your distribution.

TEST RESULTS:

Below is the error stack from stage 'make test':

PERL_DL_NONLAZY=1 "/home/cpan/pit/thr/perl-5.30.3/bin/perl" "-MExtUtils::Command::MM" "-MTest::Harness" "-e" "undef *Test::Harness::Switches; test_harness(0, 'blib/lib', 'blib/arch')" t/*.t

#   Failed test 'use Net::API::Stripe::Number;'
#   at t/001_load.t line 122.
#     Tried to use 'Net::API::Stripe::Number'.
#     Error:  Can't locate Net/API/Stripe/Number.pm in @INC (you may need to install the Net::API::Stripe::Number module) (@INC contains: /home/cpan/pit/thr/conf/perl-5.30.3/.cpanplus/5.30.3/build/b5n4U4m6EN/Net-API-Stripe-v1.0.6/blib/lib /home/cpan/pit/thr/conf/perl-5.30.3/.cpanplus/5.30.3/build/b5n4U4m6EN/Net-API-Stripe-v1.0.6/blib/arch /home/cpan/pit/jail/f5ZyhCJwZ3/lib/perl5/5.30.3/x86_64-linux-thread-multi /home/cpan/pit/jail/f5ZyhCJwZ3/lib/perl5/5.30.3/x86_64-linux-thread-multi /home/cpan/pit/jail/f5ZyhCJwZ3/lib/perl5/5.30.3 /home/cpan/pit/jail/f5ZyhCJwZ3/lib/perl5/x86_64-linux-thread-multi /home/cpan/pit/jail/f5ZyhCJwZ3/lib/perl5/5.30.3/x86_64-linux-thread-multi /home/cpan/pit/jail/f5ZyhCJwZ3/lib/perl5/5.30.3 /home/cpan/pit/jail/f5ZyhCJwZ3/lib/perl5/x86_64-linux-thread-multi /home/cpan/pit/jail/f5ZyhCJwZ3/lib/perl5 /home/cpan/pit/jail/f5ZyhCJwZ3/lib/perl5/5.30.3/x86_64-linux-thread-multi /home/cpan/pit/jail/f5ZyhCJwZ3/lib/perl5/5.30.3 /home/cpan/pit/jail/f5ZyhCJwZ3/lib/perl5/x86_64-linux-thread-multi /home/cpan/pit/jail/f5ZyhCJwZ3/lib/perl5 /home/cpan/pit/thr/conf/perl-5.30.3/.cpanplus/5.30.3/build/b5n4U4m6EN/Net-API-Stripe-v1.0.6/blib/lib /home/cpan/pit/thr/conf/perl-5.30.3/.cpanplus/5.30.3/build/b5n4U4m6EN/Net-API-Stripe-v1.0.6/blib/arch /home/cpan/pit/thr/perl-5.30.3/lib/site_perl/5.30.3/x86_64-linux-thread-multi /home/cpan/pit/thr/perl-5.30.3/lib/site_perl/5.30.3 /home/cpan/pit/thr/perl-5.30.3/lib/5.30.3/x86_64-linux-thread-multi /home/cpan/pit/thr/perl-5.30.3/lib/5.30.3 .) at t/001_load.t line 122.
# BEGIN failed--compilation aborted at t/001_load.t line 122.
# Looks like you failed 1 test of 156.
t/001_load.t .. 
Dubious, test returned 1 (wstat 256, 0x100)
Failed 1/156 subtests 
t/002_pod.t ... ok

Test Summary Report
-------------------
t/001_load.t (Wstat: 256 Tests: 156 Failed: 1)
  Failed test:  114
  Non-zero exit status: 1
Files=2, Tests=312,  5 wallclock secs ( 0.05 usr  0.00 sys +  4.52 cusr  0.06 csys =  4.63 CPU)
Result: FAIL
Failed 1/2 test programs. 1/312 subtests failed.
make: *** [Makefile:1553: test_dynamic] Error 255



MISSING PREREQUISITES:

It was observed that the test suite seem to fail without these modules:

Net::API::Stripe::Number

As such, adding the prerequisite module(s) to 'PREREQ_PM' in your
Makefile.PL should solve this problem.  For example:

WriteMakefile(
    AUTHOR      => 'JDEGUEST (cpanplus-info@lists.sf.net)',
    ... # other information
    PREREQ_PM   => {
	'Net::API::Stripe::Number'	=> '0', # or a minimum working version
    }
);

Thanks! :-)

PREREQUISITES:

Here is a list of prerequisites you specified and versions we
managed to load:

	  Module Name                        Have     Want
	  Crypt::OpenSSL::RSA                0.31     0.31
	  Cwd                                3.78     3.75
	  Data::Dumper                      2.174    2.173
	  Data::Random                       0.13     0.13
	  Data::UUID                        1.226    1.224
	  DateTime                           1.52     1.51
	  DateTime::Format::Strptime         1.77     1.76
	  DateTime::TimeZone                 2.39     2.36
	  Devel::Confess                 0.009004 0.009004
	  Digest::MD5                        2.55     2.55
	  Digest::SHA                        6.02     6.02
	  Encode                             3.01     3.01
	  ExtUtils::MakeMaker                7.44        0
	  File::Basename                     2.85     2.85
	  File::Spec                         3.78     3.75
	  HTTP::Cookies                      6.08     6.04
	  HTTP::Request                      6.24     6.18
	  IO::File                           1.41     1.41
	  JSON                               4.02     4.02
	  LWP::MediaTypes                    6.04     6.04
	  LWP::UserAgent                     6.44     6.39
	  MIME::Base64                       3.15     3.15
	  MIME::QuotedPrint                  3.13     3.13
	  Module::Generic                v0.12.14 v0.12.13
	  Net::IP                            1.26     1.26
	  Net::OAuth                         0.28     0.28
	  Nice::Try                        v0.1.4   v0.1.4
	  Scalar::Util                       1.55     1.54
	  Test::More                     1.302175        0
	  Test::Pod                          1.52        0
	  URI::Escape                        3.31     3.31
	  URI::Query                         0.16     0.16
	  Want                               0.29     0.29
	  common::sense                      3.75        0
	  constant                           1.33        0
	  overload                           1.30     1.26
	  parent                            0.237        0

Perl module toolchain versions installed:
	Module Name                        Have
	CPANPLUS                         0.9908
	CPANPLUS::Dist::Build              0.90
	Cwd                                3.78
	ExtUtils::CBuilder             0.280234
	ExtUtils::Command                  7.44
	ExtUtils::Install                  2.14
	ExtUtils::MakeMaker                7.44
	ExtUtils::Manifest                 1.72
	ExtUtils::ParseXS                  3.40
	File::Spec                         3.78
	Module::Build                    0.4231
	Pod::Parser                        1.63
	Pod::Simple                        3.35
	Test2                          1.302175
	Test::Harness                      3.42
	Test::More                     1.302175
	version                          0.9924

******************************** NOTE ********************************
The comments above are created mechanically, possibly without manual
checking by the sender.  As there are many people performing automatic
tests on each upload to CPAN, it is likely that you will receive
identical messages about the same problem.

If you believe that the message is mistaken, please reply to the first
one with correction and/or additional informations, and do not take
it personally.  We appreciate your patience. :)
**********************************************************************

Additional comments:


This report was machine-generated by CPANPLUS::Dist::YACSmoke 1.08.
Powered by minismokebox version 0.68

CPANPLUS is prefering Build.PL

------------------------------
ENVIRONMENT AND OTHER CONTEXT
------------------------------

Environment variables:

    AUTOMATED_TESTING = 1
    LANG = en_GB.UTF-8
    LANGUAGE = en_GB:en
    NONINTERACTIVE_TESTING = 1
    PATH = /usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games:/usr/local/games:/snap/bin:/snap/bin:/var/lib/snapd/snap/bin:/snap/bin:/var/lib/snapd/snap/bin:/snap/bin:/var/lib/snapd/snap/bin
    PERL5LIB = /home/cpan/pit/jail/f5ZyhCJwZ3/lib/perl5:/home/cpan/pit/thr/conf/perl-5.30.3/.cpanplus/5.30.3/build/b5n4U4m6EN/Net-API-Stripe-v1.0.6/blib/lib:/home/cpan/pit/thr/conf/perl-5.30.3/.cpanplus/5.30.3/build/b5n4U4m6EN/Net-API-Stripe-v1.0.6/blib/arch
    PERL5_CPANPLUS_IS_RUNNING = 2312477
    PERL5_CPANPLUS_IS_VERSION = 0.9908
    PERL5_MINISMOKEBOX = 0.68
    PERL5_YACSMOKE_BASE = /home/cpan/pit/thr/conf/perl-5.30.3
    PERL_EXTUTILS_AUTOINSTALL = --defaultdeps
    PERL_LOCAL_LIB_ROOT = /home/cpan/pit/jail/f5ZyhCJwZ3
    PERL_MB_OPT = --install_base "/home/cpan/pit/jail/f5ZyhCJwZ3"
    PERL_MM_OPT = INSTALL_BASE=/home/cpan/pit/jail/f5ZyhCJwZ3
    PERL_MM_USE_DEFAULT = 1
    SHELL = /bin/bash
    TERM = screen

Perl special variables (and OS-specific diagnostics, for MSWin32):

    Perl: $^X = /home/cpan/pit/thr/perl-5.30.3/bin/perl
    UID:  $<  = 1001
    EUID: $>  = 1001
    GID:  $(  = 1001 1001
    EGID: $)  = 1001 1001


-------------------------------


--

Summary of my perl5 (revision 5 version 30 subversion 3) configuration:
   
  Platform:
    osname=linux
    osvers=5.4.0-26-generic
    archname=x86_64-linux-thread-multi
    uname='linux uchder 5.4.0-26-generic #30-ubuntu smp mon apr 20 16:58:30 utc 2020 x86_64 x86_64 x86_64 gnulinux '
    config_args='-des -Dprefix=/home/cpan/pit/thr/perl-5.30.3 -Dusethreads'
    hint=recommended
    useposix=true
    d_sigaction=define
    useithreads=define
    usemultiplicity=define
    use64bitint=define
    use64bitall=define
    uselongdouble=undef
    usemymalloc=n
    default_inc_excludes_dot=define
    bincompat5005=undef
  Compiler:
    cc='cc'
    ccflags ='-D_REENTRANT -D_GNU_SOURCE -fwrapv -fno-strict-aliasing -pipe -fstack-protector-strong -I/usr/local/include -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64'
    optimize='-O2'
    cppflags='-D_REENTRANT -D_GNU_SOURCE -fwrapv -fno-strict-aliasing -pipe -fstack-protector-strong -I/usr/local/include'
    ccversion=''
    gccversion='9.3.0'
    gccosandvers=''
    intsize=4
    longsize=8
    ptrsize=8
    doublesize=8
    byteorder=12345678
    doublekind=3
    d_longlong=define
    longlongsize=8
    d_longdbl=define
    longdblsize=16
    longdblkind=3
    ivtype='long'
    ivsize=8
    nvtype='double'
    nvsize=8
    Off_t='off_t'
    lseeksize=8
    alignbytes=8
    prototype=define
  Linker and Libraries:
    ld='cc'
    ldflags =' -fstack-protector-strong -L/usr/local/lib'
    libpth=/usr/local/lib /usr/include/x86_64-linux-gnu /usr/lib /lib/x86_64-linux-gnu /lib/../lib /usr/lib/x86_64-linux-gnu /usr/lib/../lib /lib
    libs=-lpthread -lnsl -lgdbm -ldl -lm -lcrypt -lutil -lc
    perllibs=-lpthread -lnsl -ldl -lm -lcrypt -lutil -lc
    libc=libc-2.31.so
    so=so
    useshrplib=false
    libperl=libperl.a
    gnulibc_version='2.31'
  Dynamic Linking:
    dlsrc=dl_dlopen.xs
    dlext=so
    d_dlsymun=undef
    ccdlflags='-Wl,-E'
    cccdlflags='-fPIC'
    lddlflags='-shared -O2 -L/usr/local/lib -fstack-protector-strong'


Characteristics of this binary (from libperl): 
  Compile-time options:
    HAS_TIMES
    MULTIPLICITY
    PERLIO_LAYERS
    PERL_COPY_ON_WRITE
    PERL_DONT_CREATE_GVSV
    PERL_IMPLICIT_CONTEXT
    PERL_MALLOC_WRAP
    PERL_OP_PARENT
    PERL_PRESERVE_IVUV
    USE_64_BIT_ALL
    USE_64_BIT_INT
    USE_ITHREADS
    USE_LARGE_FILES
    USE_LOCALE
    USE_LOCALE_COLLATE
    USE_LOCALE_CTYPE
    USE_LOCALE_NUMERIC
    USE_LOCALE_TIME
    USE_PERLIO
    USE_PERL_ATOF
    USE_REENTRANT_API
    USE_THREAD_SAFE_LOCALE
  Locally applied patches:
    Devel::PatchPerl 1.98
  Built under linux
  Compiled at Jun  1 2020 23:31:07
  %ENV:
    PERL5LIB="/home/cpan/pit/jail/f5ZyhCJwZ3/lib/perl5:/home/cpan/pit/thr/conf/perl-5.30.3/.cpanplus/5.30.3/build/b5n4U4m6EN/Net-API-Stripe-v1.0.6/blib/lib:/home/cpan/pit/thr/conf/perl-5.30.3/.cpanplus/5.30.3/build/b5n4U4m6EN/Net-API-Stripe-v1.0.6/blib/arch"
    PERL5_CPANPLUS_IS_RUNNING="2312477"
    PERL5_CPANPLUS_IS_VERSION="0.9908"
    PERL5_MINISMOKEBOX="0.68"
    PERL5_YACSMOKE_BASE="/home/cpan/pit/thr/conf/perl-5.30.3"
    PERL_EXTUTILS_AUTOINSTALL="--defaultdeps"
    PERL_LOCAL_LIB_ROOT="/home/cpan/pit/jail/f5ZyhCJwZ3"
    PERL_MB_OPT="--install_base "/home/cpan/pit/jail/f5ZyhCJwZ3""
    PERL_MM_OPT="INSTALL_BASE=/home/cpan/pit/jail/f5ZyhCJwZ3"
    PERL_MM_USE_DEFAULT="1"
  @INC:
    /home/cpan/pit/jail/f5ZyhCJwZ3/lib/perl5/5.30.3/x86_64-linux-thread-multi
    /home/cpan/pit/jail/f5ZyhCJwZ3/lib/perl5/5.30.3
    /home/cpan/pit/jail/f5ZyhCJwZ3/lib/perl5/x86_64-linux-thread-multi
    /home/cpan/pit/jail/f5ZyhCJwZ3/lib/perl5
    /home/cpan/pit/thr/conf/perl-5.30.3/.cpanplus/5.30.3/build/b5n4U4m6EN/Net-API-Stripe-v1.0.6/blib/lib
    /home/cpan/pit/thr/conf/perl-5.30.3/.cpanplus/5.30.3/build/b5n4U4m6EN/Net-API-Stripe-v1.0.6/blib/arch
    /home/cpan/pit/thr/perl-5.30.3/lib/site_perl/5.30.3/x86_64-linux-thread-multi
    /home/cpan/pit/thr/perl-5.30.3/lib/site_perl/5.30.3
    /home/cpan/pit/thr/perl-5.30.3/lib/5.30.3/x86_64-linux-thread-multi
    /home/cpan/pit/thr/perl-5.30.3/lib/5.30.3