Swagger2-Markdown v9.99 Perl 5 v5.14.4 x86_64-linux

Status
Pass
From
Slaven Rezić (SREZIC)
Dist
Swagger2-Markdown v9.99
Platform
Perl 5 v5.14.4 x86_64-linux
Date
2017-09-07T15:21:15
ID
304f2558-93e0-11e7-acc8-ba892561e738
This distribution has been tested as part of the CPAN Testers
project, supporting the Perl programming language.  See
http://wiki.cpantesters.org/ for more information or email
questions to cpan-testers-discuss@perl.org


--
Dear Lee Johnson,

This is a computer-generated report for Swagger2-Markdown-9.99
on perl 5.14.4, created by CPAN-Reporter-1.2018.

Thank you for uploading your work to CPAN.  Congratulations!
All tests were successful.

Sections of this report:

    * Tester comments
    * Program output
    * Prerequisites
    * Environment and other context

------------------------------
TESTER COMMENTS
------------------------------

Additional comments from tester:

none provided

------------------------------
PROGRAM OUTPUT
------------------------------

Output from '/usr/bin/make test':

PERL_DL_NONLAZY=1 "/bbbike/perl-5.14.4/bin/perl5.14.4" "-MExtUtils::Command::MM" "-MTest::Harness" "-e" "undef *Test::Harness::Switches; test_harness(0, 'blib/lib', 'blib/arch')" t/*.t
Exiting subroutine via next at t/001_compiles_pod.t line 24.
t/001_compiles_pod.t .... ok
t/003_changes.t ......... ok
t/010_api_blueprint.t ... ok
Use of uninitialized value in join or string at /opt/perl-5.14.4/lib/site_perl/5.14.4/Swagger2/POD.pm line 294.
Use of uninitialized value in join or string at /opt/perl-5.14.4/lib/site_perl/5.14.4/Swagger2/POD.pm line 294.
Use of uninitialized value in join or string at /opt/perl-5.14.4/lib/site_perl/5.14.4/Swagger2/POD.pm line 294.
Use of uninitialized value in join or string at /opt/perl-5.14.4/lib/site_perl/5.14.4/Swagger2/POD.pm line 294.
t/015_basic_markdown.t .. ok
All tests successful.
Files=4, Tests=27,  3 wallclock secs ( 0.03 usr  0.01 sys +  1.09 cusr  0.11 csys =  1.24 CPU)
Result: PASS

------------------------------
PREREQUISITES
------------------------------

Prerequisite modules loaded:

requires:

    Module                Need     Have    
    --------------------- -------- --------
    File::Find            0        1.19    
    File::Slurper         0.006    0.009   
    File::Spec::Functions 0        3.62    
    Moo                   2.001001 2.003002
    perl                  5.010001 5.014004
    Pod::Markdown         3.005    3.005   
    Swagger2              0.77     0.89    
    Template              2.26     2.26    
    Test::LongString      0.17     0.17    
    Test::More            0        1.302085
    Types::Standard       1.000005 1.002001
    YAML::XS              0.59     0.65    

build_requires:

    Module                Need     Have    
    --------------------- -------- --------
    ExtUtils::MakeMaker   0        7.24    

configure_requires:

    Module                Need     Have    
    --------------------- -------- --------
    ExtUtils::MakeMaker   0        7.24    


------------------------------
ENVIRONMENT AND OTHER CONTEXT
------------------------------

Environment variables:

    LANG = C
    LC_ALL = de_DE.UTF-8
    PATH = /usr/local/bin:/usr/bin:/bin:/usr/local/sbin:/usr/sbin:/sbin:/home/cpansand/bin/linux-gnu:/home/cpansand/bin/sh:/home/cpansand/bin:/usr/games:/home/cpansand/devel:/home/eserte/src/srezic-misc/scripts
    PERL5LIB = 
    PERL5OPT = 
    PERL5_CPANPLUS_IS_RUNNING = 30219
    PERL5_CPAN_IS_RUNNING = 30219
    PERL5_CPAN_IS_RUNNING_IN_RECURSION = 30160,30219
    PERLDOC = -MPod::Perldoc::ToTextOverstrike
    PERL_BATCH = yes
    PERL_CANARY_STABILITY_NOPROMPT = 1
    PERL_CPAN_REPORTER_CONFIG = /var/tmp/cpansmoker-1023/2017090715/cpanreporter_000_config.ini
    PERL_EXTUTILS_AUTOINSTALL = --defaultdeps
    PERL_PARALLEL_SMOKER = yes
    PERL_USE_UNSAFE_INC = 1
    SHELL = /bin/zsh
    TERM = screen
    TMPDIR = /var/tmp/cpansmoker-1023/2017090715

Perl special variables (and OS-specific diagnostics, for MSWin32):

    $^X = /bbbike/perl-5.14.4/bin/perl5.14.4
    $UID/$EUID = 1023 / 1023
    $GID = 1023 1023
    $EGID = 1023 1023

Perl module toolchain versions installed:

    Module              Have    
    ------------------- --------
    CPAN                2.16    
    CPAN::Meta          2.150010
    Cwd                 3.62    
    ExtUtils::CBuilder  0.280226
    ExtUtils::Command   7.24    
    ExtUtils::Install   2.14    
    ExtUtils::MakeMaker 7.24    
    ExtUtils::Manifest  1.70    
    ExtUtils::ParseXS   3.30    
    File::Spec          3.62    
    JSON                2.94    
    JSON::PP            2.27400 
    Module::Build       0.4224  
    Module::Signature   0.80    
    Parse::CPAN::Meta   2.150010
    Test::Harness       3.38    
    Test::More          1.302085
    YAML                1.20    
    YAML::Syck          1.29    
    version             0.9916  


--

Summary of my perl5 (revision 5 version 14 subversion 4) configuration:
   
  Platform:
    osname=linux, osvers=3.16.0-4-amd64, archname=x86_64-linux
    uname='linux eserte 3.16.0-4-amd64 #1 smp debian 3.16.7-ckt25-2 (2016-04-08) x86_64 gnulinux '
    config_args='-ds -e -Dprefix=/opt/perl-5.14.4 -Dcf_email=srezic@cpan.org'
    hint=recommended, useposix=true, d_sigaction=define
    useithreads=undef, usemultiplicity=undef
    useperlio=define, d_sfio=undef, uselargefiles=define, usesocks=undef
    use64bitint=define, use64bitall=define, uselongdouble=undef
    usemymalloc=n, bincompat5005=undef
  Compiler:
    cc='cc', ccflags ='-fno-strict-aliasing -pipe -fstack-protector -I/usr/local/include -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64',
    optimize='-O2',
    cppflags='-fno-strict-aliasing -pipe -fstack-protector -I/usr/local/include'
    ccversion='', gccversion='4.9.2', gccosandvers=''
    intsize=4, longsize=8, ptrsize=8, doublesize=8, byteorder=12345678
    d_longlong=define, longlongsize=8, d_longdbl=define, longdblsize=16
    ivtype='long', ivsize=8, nvtype='double', nvsize=8, Off_t='off_t', lseeksize=8
    alignbytes=8, prototype=define
  Linker and Libraries:
    ld='cc', ldflags =' -fstack-protector -L/usr/local/lib'
    libpth=/usr/local/lib /lib/x86_64-linux-gnu /lib/../lib /usr/lib/x86_64-linux-gnu /usr/lib/../lib /lib /usr/lib
    libs=-lnsl -lgdbm -ldb -ldl -lm -lcrypt -lutil -lc -lgdbm_compat
    perllibs=-lnsl -ldl -lm -lcrypt -lutil -lc
    libc=libc-2.19.so, so=so, useshrplib=false, libperl=libperl.a
    gnulibc_version='2.19'
  Dynamic Linking:
    dlsrc=dl_dlopen.xs, dlext=so, d_dlsymun=undef, ccdlflags='-Wl,-E'
    cccdlflags='-fPIC', lddlflags='-shared -O2 -L/usr/local/lib -fstack-protector'


Characteristics of this binary (from libperl): 
  Compile-time options: PERL_DONT_CREATE_GVSV PERL_MALLOC_WRAP
                        PERL_PRESERVE_IVUV USE_64_BIT_ALL USE_64_BIT_INT
                        USE_LARGE_FILES USE_PERLIO USE_PERL_ATOF
  Locally applied patches:
	Devel::PatchPerl 1.42
  Built under linux
  Compiled at May  7 2016 10:35:43
  %ENV:
    PERL5LIB=""
    PERL5OPT=""
    PERL5_CPANPLUS_IS_RUNNING="30219"
    PERL5_CPAN_IS_RUNNING="30219"
    PERL5_CPAN_IS_RUNNING_IN_RECURSION="30160,30219"
    PERLDOC="-MPod::Perldoc::ToTextOverstrike"
    PERL_BATCH="yes"
    PERL_CANARY_STABILITY_NOPROMPT="1"
    PERL_CPAN_REPORTER_CONFIG="/var/tmp/cpansmoker-1023/2017090715/cpanreporter_000_config.ini"
    PERL_EXTUTILS_AUTOINSTALL="--defaultdeps"
    PERL_PARALLEL_SMOKER="yes"
    PERL_USE_UNSAFE_INC="1"
  @INC:
    /opt/perl-5.14.4/lib/site_perl/5.14.4/x86_64-linux
    /opt/perl-5.14.4/lib/site_perl/5.14.4
    /opt/perl-5.14.4/lib/5.14.4/x86_64-linux
    /opt/perl-5.14.4/lib/5.14.4
    .