Gnome2-VFS v1.084 Perl 5 v5.14.1 x86_64-linux

Status
Na
From
Nedzad Hrnjica (NHRNJICA)
Dist
Gnome2-VFS v1.084
Platform
Perl 5 v5.14.1 x86_64-linux
Date
2022-07-26T06:28:56
ID
3a0d77bc-0cac-11ed-b364-43070ff29030
This distribution has been tested as part of the CPAN Testers
project, supporting the Perl programming language.  See
http://wiki.cpantesters.org/ for more information or email
questions to cpan-testers-discuss@perl.org


--
Dear XAOC,

This is a computer-generated report for Gnome2-VFS-1.084
on perl 5.14.1, created by App::cpanminus::reporter 0.17 (1.7046).

Thank you for uploading your work to CPAN.  While attempting to build or test
this distribution, the distribution signaled that support is not available
either for this operating system or this version of Perl.  Nevertheless, any
diagnostic output produced is provided below for reference.  If this is not
what you expect, you may wish to consult the CPAN Testers Wiki:

http://wiki.cpantesters.org/wiki/CPANAuthorNotes

Sections of this report:

    * Tester comments
    * Program output
    * Prerequisites
    * Environment and other context

------------------------------
TESTER COMMENTS
------------------------------

Additional comments from tester:

none provided

------------------------------
PROGRAM OUTPUT
------------------------------

Output from '':

Running Makefile.PL
Can't locate Glib.pm in @INC (@INC contains: /home/liveapp/cpantesters.new/5.14.1/local/lib/perl5 /home/liveapp/.plenv/versions/5.14.1/lib/perl5/site_perl/5.14.1/x86_64-linux /home/liveapp/.plenv/versions/5.14.1/lib/perl5/site_perl/5.14.1 /home/liveapp/.plenv/versions/5.14.1/lib/perl5/5.14.1/x86_64-linux /home/liveapp/.plenv/versions/5.14.1/lib/perl5/5.14.1 .) at (eval 10) line 1.
BEGIN failed--compilation aborted at (eval 10) line 1.

MakeMaker FATAL: prerequisites not found.
    Glib not installed

Please install these modules first and rerun 'perl Makefile.PL'.
Checking if your kit is complete...
Warning: the following files are missing in your kit:
	perl-Gnome2-VFS.doap
Please inform the author.
-> N/A
-> FAIL Configure failed for Gnome2-VFS-1.084. See /home/liveapp/.cpanm/work/1658816928.1430390/build.log for details.

------------------------------
PREREQUISITES
------------------------------

Prerequisite modules loaded:

    No requirements found

------------------------------
ENVIRONMENT AND OTHER CONTEXT
------------------------------

Environment variables:

    LANG = C.UTF-8
    PATH = /home/liveapp/.plenv/versions/5.14.1/bin:/home/liveapp/.plenv/libexec:/home/liveapp/.plenv/plugins/perl-build/bin:/home/liveapp/cpantesters.new/5.14.1/local/bin:/home/liveapp/.plenv/shims:/home/liveapp/.plenv/bin:/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games:/usr/local/games:/snap/bin
    PERL5LIB = /home/liveapp/cpantesters.new/5.14.1/local/lib/perl5
    SHELL = /bin/bash
    TERM = xterm-256color

Perl special variables (and OS-specific diagnostics, for MSWin32):

    EGID = 1001 27 1001
    EUID = 1001
    EXECUTABLE_NAME = /home/liveapp/.plenv/versions/5.14.1/bin/perl5.14.1
    GID = 1001 27 1001
    UID = 1001

Perl module toolchain versions installed:

    Module              Have    
    ------------------- --------
    CPAN                1.9600  
    CPAN::Meta          2.150010
    Cwd                 3.75    
    ExtUtils::CBuilder  0.280236
    ExtUtils::Command   7.64    
    ExtUtils::Install   2.06    
    ExtUtils::MakeMaker 7.64    
    ExtUtils::Manifest  1.70    
    ExtUtils::ParseXS   3.44    
    File::Spec          3.75    
    JSON                4.07    
    JSON::PP            4.10    
    Module::Build       0.4231  
    Module::Signature   n/a     
    Parse::CPAN::Meta   2.150010
    Test::Harness       3.44    
    Test::More          1.302191
    YAML                1.30    
    YAML::Syck          n/a     
    version             0.9929  


--

Summary of my perl5 (revision 5 version 14 subversion 1) configuration:
   
  Platform:
    osname=linux, osvers=5.4.0-91-generic, archname=x86_64-linux
    uname='linux supremeadmin 5.4.0-91-generic #102-ubuntu smp fri nov 5 16:31:28 utc 2021 x86_64 x86_64 x86_64 gnulinux '
    config_args='-Dprefix=/home/liveapp/.plenv/versions/5.14.1 -de -Dversiononly -A'eval:scriptdir=/home/liveapp/.plenv/versions/5.14.1/bin''
    hint=recommended, useposix=true, d_sigaction=define
    useithreads=undef, usemultiplicity=undef
    useperlio=define, d_sfio=undef, uselargefiles=define, usesocks=undef
    use64bitint=define, use64bitall=define, uselongdouble=undef
    usemymalloc=n, bincompat5005=undef
  Compiler:
    cc='cc', ccflags ='-fwrapv -fno-strict-aliasing -pipe -fstack-protector -I/usr/local/include -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64',
    optimize='-O2',
    cppflags='-fwrapv -fno-strict-aliasing -pipe -fstack-protector -I/usr/local/include'
    ccversion='', gccversion='9.4.0', gccosandvers=''
    intsize=4, longsize=8, ptrsize=8, doublesize=8, byteorder=12345678
    d_longlong=define, longlongsize=8, d_longdbl=define, longdblsize=16
    ivtype='long', ivsize=8, nvtype='double', nvsize=8, Off_t='off_t', lseeksize=8
    alignbytes=8, prototype=define
  Linker and Libraries:
    ld='cc', ldflags =' -fstack-protector -L/usr/local/lib'
    libpth=/usr/local/lib /lib/x86_64-linux-gnu /lib/../lib /usr/lib/x86_64-linux-gnu /usr/lib/../lib /lib /usr/lib
    libs=-lnsl -ldl -lm -lcrypt -lutil -lc
    perllibs=-lnsl -ldl -lm -lcrypt -lutil -lc
    libc=libc-2.31.so, so=so, useshrplib=false, libperl=libperl.a
    gnulibc_version='2.31'
  Dynamic Linking:
    dlsrc=dl_dlopen.xs, dlext=so, d_dlsymun=undef, ccdlflags='-Wl,-E'
    cccdlflags='-fPIC', lddlflags='-shared -O2 -L/usr/local/lib -fstack-protector'


Characteristics of this binary (from libperl): 
  Compile-time options: PERL_DONT_CREATE_GVSV PERL_MALLOC_WRAP
                        PERL_PRESERVE_IVUV USE_64_BIT_ALL USE_64_BIT_INT
                        USE_LARGE_FILES USE_PERLIO USE_PERL_ATOF
  Locally applied patches:
	Devel::PatchPerl 2.08
  Built under linux
  Compiled at Jul 24 2022 13:53:49
  %ENV:
    PERL5LIB="/home/liveapp/cpantesters.new/5.14.1/local/lib/perl5"
  @INC:
    /home/liveapp/cpantesters.new/5.14.1/local/lib/perl5
    /home/liveapp/.plenv/versions/5.14.1/lib/perl5/site_perl/5.14.1/x86_64-linux
    /home/liveapp/.plenv/versions/5.14.1/lib/perl5/site_perl/5.14.1
    /home/liveapp/.plenv/versions/5.14.1/lib/perl5/5.14.1/x86_64-linux
    /home/liveapp/.plenv/versions/5.14.1/lib/perl5/5.14.1
    .