Net-RabbitMQ v0.1.5 Perl 5 v5.10.0 x86_64-netbsd-thread-multi

Status
Pass
From
Apocalypse (APOCAL)
Dist
Net-RabbitMQ v0.1.5
Platform
Perl 5 v5.10.0 x86_64-netbsd-thread-multi
Date
2010-04-26T00:43:36
ID
bfe023e8-50cc-11df-9e93-570f7b45d684
This distribution has been tested as part of the CPAN Testers
project, supporting the Perl programming language.  See
http://wiki.cpantesters.org/ for more information or email
questions to cpan-testers-discuss@perl.org


--

Dear JESUS,
    
This is a computer-generated error report created automatically by
CPANPLUS, version 0.9003. Testers personal comments may appear 
at the end of this report.

MAKE TEST passed: PERL_DL_NONLAZY=1 /usr/pkg/bin/perl "-MExtUtils::Command::MM" "-e" "test_harness(0, 'blib/lib', 'blib/arch')" t/*.t
t/001_declare_exchange.t .. ok
t/002_publish.t ........... ok
t/003_consume.t ........... ok
t/004_selfconsume.t ....... ok
t/005_noack.t ............. ok
t/006_txn.t ............... ok
t/007_get.t ............... ok
t/008_queue_declare.t ..... ok
All tests successful.
Files=8, Tests=77, 21 wallclock secs ( 0.04 usr  0.19 sys +  0.11 cusr  0.38 csys =  0.72 CPU)
Result: PASS

[MSG] [Sun Apr 25 17:43:30 2010] Sending test report for 'Net-RabbitMQ-0.1.5'

This report was machine-generated by CPANPLUS::Dist::YACSmoke 0.54.

------------------------------
ENVIRONMENT AND OTHER CONTEXT
------------------------------

Environment variables:

    AUTOMATED_TESTING = 1
    PATH = /home/cpan/bin:/bin:/sbin:/usr/bin:/usr/sbin:/usr/X11R7/bin:/usr/X11R6/bin:/usr/pkg/bin:/usr/pkg/sbin:/usr/games:/usr/local/bin:/usr/local/sbin
    PERL5LIB = :/home/cpan/.cpanplus/5.10.0/build/Net-RabbitMQ-0.1.5/blib/lib:/home/cpan/.cpanplus/5.10.0/build/Net-RabbitMQ-0.1.5/blib/arch
    PERL5_CPANIDX_URL = http://192.168.0.200:11110/CPANIDX/
    PERL5_CPANPLUS_IS_RUNNING = 20104
    PERL5_CPANPLUS_IS_VERSION = 0.9003
    PERL5_YACSMOKE_BASE = /home/cpan
    PERL_CPANSMOKER_HOST = /usr/pkg/bin/perl / NetBSD 5.0.1 amd64 (192.168.0.205)
    PERL_EXTUTILS_AUTOINSTALL = --defaultdeps
    PERL_MM_USE_DEFAULT = 1
    SHELL = /usr/pkg/bin/bash
    TERM = xterm

Perl special variables (and OS-specific diagnostics, for MSWin32):

    Perl: $^X = /usr/pkg/bin/perl
    UID:  $<  = 1001
    EUID: $>  = 1001
    GID:  $(  = 100 100
    EGID: $)  = 100 100


-------------------------------


--

Summary of my perl5 (revision 5 version 10 subversion 0) configuration:
  Platform:
    osname=netbsd, osvers=5.0.1, archname=x86_64-netbsd-thread-multi
    uname='netbsd netbsd64 5.0.1 netbsd 5.0.1 (generic) #0: thu jul 30 00:08:07 utc 2009 builds@b7.netbsd.org:homebuildsabnetbsd-5-0-1-releaseamd64200907292356z-objhomebuildsabnetbsd-5-0-1-releasesrcsysarchamd64compilegeneric amd64 '
    config_args='-sde -Darchname=x86_64-netbsd -Dcc=cc -Doptimize=-O2 -pthread -I/usr/include -Ui_malloc -Uinstallusrbinperl -Dinstallstyle=lib/perl5 -Dprefix=/usr/pkg -Dsiteprefix=/usr/pkg -Dvendorprefix=/usr/pkg -Dscriptdir=/usr/pkg/lib/perl5/bin -Dsitescript=/usr/pkg/lib/perl5/site_perl/bin -Dvendorscript=/usr/pkg/lib/perl5/vendor_perl/bin -Dsitebin=/usr/pkg/lib/perl5/site_perl/bin -Dvendorbin=/usr/pkg/lib/perl5/vendor_perl/bin -Dprivlib=/usr/pkg/lib/perl5/5.10.0 -Dsitelib=/usr/pkg/lib/perl5/site_perl/5.10.0 -Dvendorlib=/usr/pkg/lib/perl5/vendor_perl/5.10.0 -Dsitelib_stem=/usr/pkg/lib/perl5/site_perl -Dvendorlib_stem=/usr/pkg/lib/perl5/vendor_perl -Dman1ext=1 -Dman1dir=/usr/pkg/lib/perl5/man/man1 -Dsiteman1dir=/usr/pkg/lib/perl5/site_perl/man/man1 -Dvendorman1dir=/usr/pkg/lib/perl5/vendor_perl/man/man1 -Dman3ext=3 -Dman3dir=/usr/pkg/lib/perl5/man/man3 -Dsiteman3dir=/usr/pkg/lib/perl5/site_perl/man/man3 -Dvendorman3dir=/usr/pkg/lib/perl5/vendor_perl/man/man3 -Duseshrplib -Daphostname=/bin/hostname -Dln=/bin/ln -Dsed=/usr/bin/sed -Dsh=/bin/sh -Dissymlink=test -h -Dperl5=false -Duseithreads -Uusemymalloc -Dlibswanted=m crypt '
    hint=recommended, useposix=true, d_sigaction=define
    useithreads=define, usemultiplicity=define
    useperlio=define, d_sfio=undef, uselargefiles=define, usesocks=undef
    use64bitint=define, use64bitall=define, uselongdouble=undef
    usemymalloc=n, bincompat5005=undef
  Compiler:
    cc='cc', ccflags ='-fno-strict-aliasing -pipe',
    optimize='-O2 -pthread -I/usr/include',
    cppflags='-fno-strict-aliasing -pipe'
    ccversion='', gccversion='4.1.3 20080704 prerelease (NetBSD nb2 20081120)', gccosandvers=''
    intsize=4, longsize=8, ptrsize=8, doublesize=8, byteorder=12345678
    d_longlong=define, longlongsize=8, d_longdbl=define, longdblsize=16
    ivtype='long', ivsize=8, nvtype='double', nvsize=8, Off_t='off_t', lseeksize=8
    alignbytes=8, prototype=define
  Linker and Libraries:
    ld='cc', ldflags ='-Wl,-R/usr/pkg/lib  -L/usr/pkg/lib'
    libpth=/usr/lib /usr/pkg/lib
    libs=-lm -lcrypt -lpthread
    perllibs=-lm -lcrypt -lpthread
    libc=/lib/libc.so, so=so, useshrplib=true, libperl=libperl.so
    gnulibc_version=''
  Dynamic Linking:
    dlsrc=dl_dlopen.xs, dlext=so, d_dlsymun=undef, ccdlflags='-Wl,-E  -Wl,-R/usr/pkg/lib/perl5/5.10.0/x86_64-netbsd-thread-multi/CORE'
    cccdlflags='-DPIC -fPIC ', lddlflags='-Wl,-R/usr/pkg/lib --whole-archive -shared  -L/usr/pkg/lib'


Characteristics of this binary (from libperl): 
  Compile-time options: MULTIPLICITY PERL_DONT_CREATE_GVSV
                        PERL_IMPLICIT_CONTEXT USE_64_BIT_ALL USE_64_BIT_INT
                        USE_ITHREADS USE_LARGE_FILES USE_PERLIO
                        USE_REENTRANT_API
  Built under netbsd
  Compiled at Dec  3 2009 15:45:38
  %ENV:
    PERL5LIB=":/home/cpan/.cpanplus/5.10.0/build/Net-RabbitMQ-0.1.5/blib/lib:/home/cpan/.cpanplus/5.10.0/build/Net-RabbitMQ-0.1.5/blib/arch"
    PERL5_CPANIDX_URL="http://192.168.0.200:11110/CPANIDX/"
    PERL5_CPANPLUS_IS_RUNNING="20104"
    PERL5_CPANPLUS_IS_VERSION="0.9003"
    PERL5_YACSMOKE_BASE="/home/cpan"
    PERL_CPANSMOKER_HOST="/usr/pkg/bin/perl / NetBSD 5.0.1 amd64 (192.168.0.205)"
    PERL_EXTUTILS_AUTOINSTALL="--defaultdeps"
    PERL_MM_USE_DEFAULT="1"
  @INC:
    /home/cpan/.cpanplus/5.10.0/build/Net-RabbitMQ-0.1.5/blib/lib
    /home/cpan/.cpanplus/5.10.0/build/Net-RabbitMQ-0.1.5/blib/arch
    /usr/pkg/lib/perl5/site_perl/5.10.0/x86_64-netbsd-thread-multi
    /usr/pkg/lib/perl5/site_perl/5.10.0
    /usr/pkg/lib/perl5/vendor_perl/5.10.0/x86_64-netbsd-thread-multi
    /usr/pkg/lib/perl5/vendor_perl/5.10.0
    /usr/pkg/lib/perl5/vendor_perl
    /usr/pkg/lib/perl5/5.10.0/x86_64-netbsd-thread-multi
    /usr/pkg/lib/perl5/5.10.0
    .