Net-API-Stripe vv1.0.3 Perl 5 v5.18.2 amd64-freebsd

Status
Pass
From
Slaven Rezić (SREZIC)
Dist
Net-API-Stripe vv1.0.3
Platform
Perl 5 v5.18.2 amd64-freebsd
Date
2020-05-16T01:44:53
ID
d6e30ee8-9716-11ea-934e-59831f24ea8f
This distribution has been tested as part of the CPAN Testers
project, supporting the Perl programming language.  See
http://wiki.cpantesters.org/ for more information or email
questions to cpan-testers-discuss@perl.org


--
Dear Jacques Deguest,

This is a computer-generated report for Net-API-Stripe-v1.0.3
on perl 5.18.2, created by CPAN-Reporter-1.2018.

Thank you for uploading your work to CPAN.  Congratulations!
All tests were successful.

Sections of this report:

    * Tester comments
    * Program output
    * Prerequisites
    * Environment and other context

------------------------------
TESTER COMMENTS
------------------------------

Additional comments from tester:

none provided

------------------------------
PROGRAM OUTPUT
------------------------------

Output from '/usr/bin/make test':

PERL_DL_NONLAZY=1 "/usr/perl5.18.2/bin/perl" "-MExtUtils::Command::MM" "-MTest::Harness" "-e" "undef *Test::Harness::Switches; test_harness(0, 'blib/lib', 'blib/arch')" t/*.t
Ambiguous use of -customer resolved as -&customer() at /usr/home/cpansand/.cpan/build/2020051603/Net-API-Stripe-v1.0.3-1/blib/lib/Net/API/Stripe.pm line 2360.
	require Net/API/Stripe.pm called at t/001_load.t line 9
	main::BEGIN() called at /usr/home/cpansand/.cpan/build/2020051603/Net-API-Stripe-v1.0.3-1/blib/lib/Net/API/Stripe.pm line 2360
	eval {...} called at /usr/home/cpansand/.cpan/build/2020051603/Net-API-Stripe-v1.0.3-1/blib/lib/Net/API/Stripe.pm line 2360
	eval 'package main;
BEGIN { ${^WARNING_BITS} = $args[-1] if defined $args[-1] }
#line 9 t/001_load.t
use Net::API::Stripe @{$args[0]};
1;
' called at /usr/perl5.18.2/lib/site_perl/5.18.2/Test/More.pm line 1034
	Test::More::_eval("package main;\x{a}BEGIN { \${^WARNING_BITS} = \$args[-1] if defined"..., ARRAY(0x8028c7090), undef) called at /usr/perl5.18.2/lib/site_perl/5.18.2/Test/More.pm line 1009
	Test::More::use_ok("Net::API::Stripe") called at t/001_load.t line 9
	main::BEGIN() called at /usr/home/cpansand/.cpan/build/2020051603/Net-API-Stripe-v1.0.3-1/blib/lib/Net/API/Stripe.pm line 2360
	eval {...} called at /usr/home/cpansand/.cpan/build/2020051603/Net-API-Stripe-v1.0.3-1/blib/lib/Net/API/Stripe.pm line 2360
t/001_load.t .. ok
t/002_pod.t ... ok
All tests successful.
Files=2, Tests=315,  1 wallclock secs ( 0.00 usr  0.08 sys +  1.26 cusr  0.11 csys =  1.45 CPU)
Result: PASS

------------------------------
PREREQUISITES
------------------------------

Prerequisite modules loaded:

requires:

    Module                     Need     Have    
    -------------------------- -------- --------
    common::sense              0        3.74    
    constant                   0        1.33    
    Crypt::OpenSSL::RSA        0.31     0.31    
  ! Cwd                        3.78     3.75    
  ! Data::Dumper               2.174    2.173   
    Data::Random               0.13     0.13    
    Data::UUID                 1.224    1.226   
    DateTime                   1.51     1.51    
    DateTime::Format::Strptime 1.76     1.77    
    DateTime::TimeZone         2.36     2.38    
    Devel::Confess             0.009004 0.009004
    Digest::MD5                2.55     2.55    
    Digest::SHA                6.02     6.02    
    Encode                     3.01     3.03    
  ! File::Basename             2.85     2.84    
  ! File::Spec                 3.78     3.75    
    HTTP::Cookies              6.04     6.04    
    HTTP::Request              6.18     6.24    
    IO::File                   1.41     1.41    
    JSON                       4.02     4.02    
    LWP::MediaTypes            6.04     6.04    
    LWP::UserAgent             6.39     6.44    
    MIME::Base64               3.15     3.15    
    MIME::QuotedPrint          3.13     3.13    
    Module::Generic            v0.11.6  v0.12.1 
  ! Net::API::REST             v0.5.3   n/a     
    Net::IP                    1.26     1.26    
    Net::OAuth                 0.28     0.28    
  ! overload                   1.30     1.22    
    parent                     0        0.238   
    perl                       5.006000 5.018002
    Scalar::Util               1.54     1.55    
    TryCatch                   1.003002 1.003002
    URI::Escape                3.31     3.31    
    URI::Query                 0.16     0.16    
    Want                       0.29     0.29    

build_requires:

    Module                     Need     Have    
    -------------------------- -------- --------
    ExtUtils::MakeMaker        0        7.44    
    Test::Pod                  0        1.52    
    Test::Simple               0        1.302175

configure_requires:

    Module                     Need     Have    
    -------------------------- -------- --------
    ExtUtils::MakeMaker        0        7.44    


------------------------------
ENVIRONMENT AND OTHER CONTEXT
------------------------------

Environment variables:

    LC_ALL = de_DE.ISO8859-1
    PATH = /usr/local/bin:/usr/bin:/bin:/usr/local/sbin:/usr/sbin:/sbin:/home/cpansand/bin/freebsd9.3:/home/cpansand/bin/sh:/home/cpansand/bin:/usr/games:/home/cpansand/devel:/usr/home/eserte/src/srezic-misc/scripts
    PERL5LIB = 
    PERL5OPT = 
    PERL5_CPANPLUS_IS_RUNNING = 38649
    PERL5_CPAN_IS_RUNNING = 38649
    PERL5_CPAN_IS_RUNNING_IN_RECURSION = 36562,38649
    PERLDOC = -MPod::Perldoc::ToTextOverstrike
    PERL_BATCH = yes
    PERL_CANARY_STABILITY_NOPROMPT = 1
    PERL_CPAN_REPORTER_CONFIG = /var/tmp/cpansmoker-1023/2020051603/cpanreporter_000_config.ini
    PERL_EXTUTILS_AUTOINSTALL = --defaultdeps
    PERL_USE_UNSAFE_INC = 1
    SHELL = /usr/local/bin/zsh
    TERM = screen
    TMPDIR = /var/tmp/cpansmoker-1023/2020051603

Perl special variables (and OS-specific diagnostics, for MSWin32):

    $^X = /usr/perl5.18.2/bin/perl
    $UID/$EUID = 1023 / 1023
    $GID = 1023 1023
    $EGID = 1023 1023

Perl module toolchain versions installed:

    Module              Have    
    ------------------- --------
    CPAN                2.27    
    CPAN::Meta          2.150010
    Cwd                 3.75    
    ExtUtils::CBuilder  0.280231
    ExtUtils::Command   7.44    
    ExtUtils::Install   2.14    
    ExtUtils::MakeMaker 7.44    
    ExtUtils::Manifest  1.72    
    ExtUtils::ParseXS   3.35    
    File::Spec          3.75    
    JSON                4.02    
    JSON::PP            4.04    
    Module::Build       0.4229  
    Module::Signature   0.83    
    Parse::CPAN::Meta   2.150010
    Test::Harness       3.42    
    Test::More          1.302175
    YAML                1.30    
    YAML::Syck          1.32    
    version             0.9924  


--

Summary of my perl5 (revision 5 version 18 subversion 2) configuration:
   
  Platform:
    osname=freebsd, osvers=9.2-release-p4, archname=amd64-freebsd
    uname='freebsd cvrsnica-freebsd-92 9.2-release-p4 freebsd 9.2-release-p4 #0: tue apr 8 18:08:22 utc 2014 root@amd64-builder.daemonology.net:usrobjusrsrcsysgeneric amd64 '
    config_args='-ds -e -Dprefix=/usr/perl5.18.2'
    hint=recommended, useposix=true, d_sigaction=define
    useithreads=undef, usemultiplicity=undef
    useperlio=define, d_sfio=undef, uselargefiles=define, usesocks=undef
    use64bitint=define, use64bitall=define, uselongdouble=undef
    usemymalloc=n, bincompat5005=undef
  Compiler:
    cc='cc', ccflags ='-DHAS_FPSETMASK -DHAS_FLOATINGPOINT_H -fno-strict-aliasing -pipe -fstack-protector -I/usr/local/include',
    optimize='-O',
    cppflags='-DHAS_FPSETMASK -DHAS_FLOATINGPOINT_H -fno-strict-aliasing -pipe -fstack-protector -I/usr/local/include'
    ccversion='', gccversion='4.2.1 20070831 patched [FreeBSD]', gccosandvers=''
    intsize=4, longsize=8, ptrsize=8, doublesize=8, byteorder=12345678
    d_longlong=define, longlongsize=8, d_longdbl=define, longdblsize=16
    ivtype='long', ivsize=8, nvtype='double', nvsize=8, Off_t='off_t', lseeksize=8
    alignbytes=8, prototype=define
  Linker and Libraries:
    ld='cc', ldflags ='-Wl,-E  -fstack-protector -L/usr/local/lib'
    libpth=/usr/lib /usr/local/lib
    libs=-lgdbm -lm -lcrypt -lutil -lc
    perllibs=-lm -lcrypt -lutil -lc
    libc=, so=so, useshrplib=false, libperl=libperl.a
    gnulibc_version=''
  Dynamic Linking:
    dlsrc=dl_dlopen.xs, dlext=so, d_dlsymun=undef, ccdlflags=' '
    cccdlflags='-DPIC -fPIC', lddlflags='-shared  -L/usr/local/lib -fstack-protector'


Characteristics of this binary (from libperl): 
  Compile-time options: HAS_TIMES PERLIO_LAYERS PERL_DONT_CREATE_GVSV
                        PERL_HASH_FUNC_ONE_AT_A_TIME_HARD PERL_MALLOC_WRAP
                        PERL_PRESERVE_IVUV PERL_SAWAMPERSAND USE_64_BIT_ALL
                        USE_64_BIT_INT USE_LARGE_FILES USE_LOCALE
                        USE_LOCALE_COLLATE USE_LOCALE_CTYPE
                        USE_LOCALE_NUMERIC USE_PERLIO USE_PERL_ATOF
  Built under freebsd
  Compiled at May 16 2014 01:27:28
  %ENV:
    PERL5LIB=""
    PERL5OPT=""
    PERL5_CPANPLUS_IS_RUNNING="38649"
    PERL5_CPAN_IS_RUNNING="38649"
    PERL5_CPAN_IS_RUNNING_IN_RECURSION="36562,38649"
    PERLDOC="-MPod::Perldoc::ToTextOverstrike"
    PERL_BATCH="yes"
    PERL_CANARY_STABILITY_NOPROMPT="1"
    PERL_CPAN_REPORTER_CONFIG="/var/tmp/cpansmoker-1023/2020051603/cpanreporter_000_config.ini"
    PERL_EXTUTILS_AUTOINSTALL="--defaultdeps"
    PERL_USE_UNSAFE_INC="1"
  @INC:
    /usr/perl5.18.2/lib/site_perl/5.18.2/amd64-freebsd
    /usr/perl5.18.2/lib/site_perl/5.18.2
    /usr/perl5.18.2/lib/5.18.2/amd64-freebsd
    /usr/perl5.18.2/lib/5.18.2
    .