Gnome2-VFS v1.084 Perl 5 v5.30.3 sparc64-openbsd

Status
Unknown
From
Dist
Gnome2-VFS v1.084
Platform
Perl 5 v5.30.3 sparc64-openbsd
Date
2021-01-06T13:48:27
ID
da4f385e-5025-11eb-acac-c0e42759e05f
This distribution has been tested as part of the CPAN Testers
project, supporting the Perl programming language.  See
http://wiki.cpantesters.org/ for more information or email
questions to cpan-testers-discuss@perl.org


--
Dear Brian Manning,

This is a computer-generated report for Gnome2-VFS-1.084
on perl 5.30.3, created by CPAN-Reporter-1.2018.

Thank you for uploading your work to CPAN.  However, attempting to
test your distribution gave an inconclusive result.

This could be because your distribution had an error during the make/build
stage, did not define tests, tests could not be found, because your tests were
interrupted before they finished, or because the results of the tests could not
be parsed.  You may wish to consult the CPAN Testers Wiki:

http://wiki.cpantesters.org/wiki/CPANAuthorNotes

Sections of this report:

    * Tester comments
    * Program output
    * Prerequisites
    * Environment and other context

------------------------------
TESTER COMMENTS
------------------------------

Additional comments from tester:

this report is from an automated smoke testing program
and was not reviewed by a human for accuracy

------------------------------
PROGRAM OUTPUT
------------------------------

Output from '/usr/bin/perl Makefile.PL':

Can't locate Glib.pm in @INC (you may need to install the Glib module) (@INC contains: /tmp/CPAN-Reporter-lib-sXVA /home/smoker/perl/system/lib/perl5/sparc64-openbsd /home/smoker/perl/system/lib/perl5 /usr/local/libdata/perl5/site_perl/sparc64-openbsd /usr/local/libdata/perl5/site_perl /usr/libdata/perl5/sparc64-openbsd /usr/libdata/perl5 .) at (eval 10) line 1.
BEGIN failed--compilation aborted at (eval 10) line 1.

Checking if your kit is complete...
Warning: the following files are missing in your kit:
	perl-Gnome2-VFS.doap
Please inform the author.
MakeMaker FATAL: prerequisites not found.
    Glib not installed

Please install these modules first and rerun 'perl Makefile.PL'.

------------------------------
PREREQUISITES
------------------------------

Prerequisite modules loaded:

configure_requires:

    Module              Need Have
    ------------------- ---- ----
    ExtUtils::MakeMaker 0    7.58


------------------------------
ENVIRONMENT AND OTHER CONTEXT
------------------------------

Environment variables:

    AUTOMATED_TESTING = 1
    NONINTERACTIVE_TESTING = 1
    PATH = /home/smoker/perl/system/bin:/home/smoker/.plenv/libexec:/home/smoker/.plenv/plugins/perl-build/bin:/home/smoker/.plenv/plugins/plenv-contrib/bin:/home/smoker/.plenv/shims:/home/smoker/.plenv/bin:/home/smoker/bin:/bin:/sbin:/usr/bin:/usr/sbin:/usr/X11R6/bin:/usr/local/bin:/usr/local/sbin:/usr/games
    PERL = /usr/bin/perl
    PERL5LIB = /home/smoker/perl/system/lib/perl5
    PERL5OPT = -I/tmp/CPAN-Reporter-lib-sXVA -MDevel::Autoflush
    PERL5_CPANPLUS_IS_RUNNING = 93028
    PERL5_CPAN_IS_EXECUTING = /home/smoker/.cpan/build/Gnome2-VFS-1.084-0/Makefile.PL
    PERL5_CPAN_IS_RUNNING = 93028
    PERL5_CPAN_IS_RUNNING_IN_RECURSION = 5279,93028
    PERL_AUTOINSTALL = --defaultdeps
    PERL_CARTON_PATH = /home/afresh1/cpan-smoker-setup/local/system
    PERL_CR_SMOKER_CURRENT = Gnome2-VFS-1.084
    PERL_EXTUTILS_AUTOINSTALL = --defaultdeps
    PERL_LOCAL_LIB_ROOT = /home/smoker/perl/system
    PERL_MB_OPT = --install_base '/home/smoker/perl/system'
    PERL_MM_OPT = INSTALL_BASE=/home/smoker/perl/system
    PERL_MM_USE_DEFAULT = 1
    PERL_USE_UNSAFE_INC = 1
    SHELL = /bin/ksh
    TERM = screen

Perl special variables (and OS-specific diagnostics, for MSWin32):

    $^X = /usr/bin/perl
    $UID/$EUID = 900 / 900
    $GID = 900 900
    $EGID = 900 900

Perl module toolchain versions installed:

    Module              Have    
    ------------------- --------
    CPAN                2.22    
    CPAN::Meta          2.150010
    Cwd                 3.78    
    ExtUtils::CBuilder  0.280235
    ExtUtils::Command   7.58    
    ExtUtils::Install   2.20    
    ExtUtils::MakeMaker 7.58    
    ExtUtils::Manifest  1.72    
    ExtUtils::ParseXS   3.40    
    File::Spec          3.78    
    JSON                4.02    
    JSON::PP            4.05    
    Module::Build       0.4231  
    Module::Signature   0.87    
    Parse::CPAN::Meta   2.150010
    Test::Harness       3.42    
    Test::More          1.302183
    YAML                1.30    
    YAML::Syck          1.34    
    version             0.9924  


--

Summary of my perl5 (revision 5 version 30 subversion 3) configuration:
   
  Platform:
    osname=openbsd
    osvers=6.8
    archname=sparc64-openbsd
    uname='openbsd'
    config_args='-dse -Dopenbsd_distribution=defined -Dmksymlinks'
    hint=recommended
    useposix=true
    d_sigaction=define
    useithreads=undef
    usemultiplicity=undef
    use64bitint=define
    use64bitall=define
    uselongdouble=undef
    usemymalloc=n
    default_inc_excludes_dot=define
    bincompat5005=undef
  Compiler:
    cc='cc'
    ccflags ='-DNO_LOCALE_NUMERIC -DNO_LOCALE_COLLATE -fno-strict-aliasing -fno-delete-null-pointer-checks -pipe -fstack-protector-strong -D_FORTIFY_SOURCE=2 -I/usr/local/include'
    optimize='-O2'
    cppflags='-DBIG_TIME -DNO_LOCALE_NUMERIC -DNO_LOCALE_COLLATE -fno-strict-aliasing -fno-delete-null-pointer-checks -pipe -fstack-protector-strong -I/usr/local/include'
    ccversion=''
    gccversion='4.2.1 20070719 '
    gccosandvers='openbsd6.8'
    intsize=4
    longsize=8
    ptrsize=8
    doublesize=8
    byteorder=87654321
    doublekind=4
    d_longlong=define
    longlongsize=8
    d_longdbl=define
    longdblsize=16
    longdblkind=2
    ivtype='long'
    ivsize=8
    nvtype='double'
    nvsize=8
    Off_t='off_t'
    lseeksize=8
    alignbytes=8
    prototype=define
  Linker and Libraries:
    ld='cc'
    ldflags ='-Wl,-E  -fstack-protector-strong -L/usr/local/lib'
    libpth=/usr/lib /usr/lib
    libs=-lm -lc
    perllibs=-lm -lc
    libc=/usr/lib/libc.so.96.0
    so=so
    useshrplib=true
    libperl=libperl.so.20.0
    gnulibc_version=''
  Dynamic Linking:
    dlsrc=dl_dlopen.xs
    dlext=so
    d_dlsymun=undef
    ccdlflags='-Wl,-R/usr/libdata/perl5/sparc64-openbsd/CORE'
    cccdlflags='-DPIC -fPIC '
    lddlflags='-shared -fPIC  -fstack-protector-strong -L/usr/local/lib'


Characteristics of this binary (from libperl): 
  Compile-time options:
    HAS_TIMES
    PERLIO_LAYERS
    PERL_COPY_ON_WRITE
    PERL_DONT_CREATE_GVSV
    PERL_MALLOC_WRAP
    PERL_OP_PARENT
    PERL_PRESERVE_IVUV
    USE_64_BIT_ALL
    USE_64_BIT_INT
    USE_LARGE_FILES
    USE_LOCALE
    USE_LOCALE_CTYPE
    USE_LOCALE_TIME
    USE_PERLIO
    USE_PERL_ATOF
  Built under openbsd
  %ENV:
    PERL="/usr/bin/perl"
    PERL5LIB="/home/smoker/perl/system/lib/perl5"
    PERL5OPT=""
    PERL5_CPANPLUS_IS_RUNNING="93028"
    PERL5_CPAN_IS_EXECUTING="/home/smoker/.cpan/build/Gnome2-VFS-1.084-0/Makefile.PL"
    PERL5_CPAN_IS_RUNNING="93028"
    PERL5_CPAN_IS_RUNNING_IN_RECURSION="5279,93028"
    PERL_AUTOINSTALL="--defaultdeps"
    PERL_CARTON_PATH="/home/afresh1/cpan-smoker-setup/local/system"
    PERL_CR_SMOKER_CURRENT="Gnome2-VFS-1.084"
    PERL_EXTUTILS_AUTOINSTALL="--defaultdeps"
    PERL_LOCAL_LIB_ROOT="/home/smoker/perl/system"
    PERL_MB_OPT="--install_base '/home/smoker/perl/system'"
    PERL_MM_OPT="INSTALL_BASE=/home/smoker/perl/system"
    PERL_MM_USE_DEFAULT="1"
    PERL_USE_UNSAFE_INC="1"
  @INC:
    /home/smoker/perl/system/lib/perl5/sparc64-openbsd
    /home/smoker/perl/system/lib/perl5
    /usr/local/libdata/perl5/site_perl/sparc64-openbsd
    /usr/local/libdata/perl5/site_perl
    /usr/libdata/perl5/sparc64-openbsd
    /usr/libdata/perl5
    .