Locale-CLDR-Locales-Hi vv0.44.1 Perl 5 v5.39.8 aarch64-freebsd

Status
Pass
From
Slaven Rezić
Dist
Locale-CLDR-Locales-Hi vv0.44.1
Platform
Perl 5 v5.39.8 aarch64-freebsd
Date
2024-03-01T05:10:03
ID
f5e961ea-d789-11ee-ba08-57e16d8775ea
This distribution has been tested as part of the CPAN Testers
project, supporting the Perl programming language.  See
http://wiki.cpantesters.org/ for more information or email
questions to cpan-testers-discuss@perl.org


--
Dear John Imrie,

This is a computer-generated report for Locale-CLDR-Locales-Hi-v0.44.1
on perl 5.39.8, created by CPAN-Reporter-1.2019.

Thank you for uploading your work to CPAN.  Congratulations!
All tests were successful.

Sections of this report:

    * Tester comments
    * Program output
    * Prerequisites
    * Environment and other context

------------------------------
TESTER COMMENTS
------------------------------

Additional comments from tester:

none provided

------------------------------
PROGRAM OUTPUT
------------------------------

Output from './Build test':

# Testing Locale::CLDR v0.44.1, Perl 5.039008, /usr/perl5.39.8/bin/perl5.39.8
t/00-load.t .. ok
All tests successful.
Files=1, Tests=6,  0 wallclock secs ( 0.02 usr  0.00 sys +  0.51 cusr  0.08 csys =  0.61 CPU)
Result: PASS

------------------------------
PREREQUISITES
------------------------------

Prerequisite modules loaded:

requires:

    Module                              Need    Have    
    ----------------------------------- ------- --------
    DateTime                            0.72    1.65    
    Locale::CLDR                        v0.44.1 v0.44.1 
    Locale::CLDR::Locales::En::Latn::In v0.44.1 v0.44.1 
    Moo                                 2       2.005005
    MooX::ClassAttribute                0.011   0.011   
    perl                                v5.10.1 5.039008
    Type::Tiny                          0       2.004000
    version                             0.95    0.9930  

build_requires:

    Module                              Need    Have    
    ----------------------------------- ------- --------
    ok                                  0       1.302198
    Test::Exception                     0       0.43    
    Test::More                          0.98    1.302198

configure_requires:

    Module                              Need    Have    
    ----------------------------------- ------- --------
    Module::Build                       0.40    0.4234  


------------------------------
ENVIRONMENT AND OTHER CONTEXT
------------------------------

Environment variables:

    LANG = C.UTF-8
    PATH = /usr/local/bin:/usr/bin:/bin:/usr/local/sbin:/usr/sbin:/sbin:/home/cpansand/bin/sh:/home/cpansand/bin:/usr/games:/home/cpansand/devel:/home/eserte/src/srezic-misc/scripts
    PERL5LIB = 
    PERL5OPT = 
    PERL5_CPANPLUS_IS_RUNNING = 5224
    PERL5_CPAN_IS_RUNNING = 5224
    PERL5_CPAN_IS_RUNNING_IN_RECURSION = 78614,5224
    PERL_BATCH = yes
    PERL_CANARY_STABILITY_NOPROMPT = 1
    PERL_CPAN_REPORTER_CONFIG = /var/tmp/cpansmoker-1023/2024030103/cpanreporter_000_config.ini
    PERL_EXTUTILS_AUTOINSTALL = --defaultdeps
    PERL_USE_UNSAFE_INC = 1
    SHELL = /bin/sh
    TMPDIR = /var/tmp/cpansmoker-1023/2024030103

Perl special variables (and OS-specific diagnostics, for MSWin32):

    $^X = /usr/perl5.39.8/bin/perl5.39.8
    $UID/$EUID = 1023 / 1023
    $GID = 1023 1023
    $EGID = 1023 1023

Perl module toolchain versions installed:

    Module              Have    
    ------------------- --------
    CPAN                2.36    
    CPAN::Meta          2.150010
    Cwd                 3.90    
    ExtUtils::CBuilder  0.280240
    ExtUtils::Command   7.70    
    ExtUtils::Install   2.22    
    ExtUtils::MakeMaker 7.70    
    ExtUtils::Manifest  1.75    
    ExtUtils::ParseXS   3.51    
    File::Spec          3.90    
    JSON                4.10    
    JSON::PP            4.16    
    Module::Build       0.4234  
    Module::Signature   n/a     
    Parse::CPAN::Meta   2.150010
    Test2               1.302198
    Test::Harness       3.48    
    Test::More          1.302198
    YAML                1.31    
    YAML::Syck          1.34    
    version             0.9930  


--

Summary of my perl5 (revision 5 version 39 subversion 8) configuration:
   
  Platform:
    osname=freebsd
    osvers=14.0-stable
    archname=aarch64-freebsd
    uname='freebsd cloud9.bbbike.org 14.0-stable freebsd 14.0-stable #18 stable14-be2c6fba9: sun feb 25 02:50:03 utc 2024 root@cloud9.bbbike.org:usrobjhomeprojectsfreebsd-srcarm64.aarch64sysgeneric arm64 '
    config_args='-ds -e -Dprefix=/usr/perl5.39.8 -Dusedevel -Dusemallocwrap=no -Dcf_email=srezic@cpan.org -Doptimize=-O2 -pipe'
    hint=recommended
    useposix=true
    d_sigaction=define
    useithreads=undef
    usemultiplicity=undef
    use64bitint=define
    use64bitall=define
    uselongdouble=undef
    usemymalloc=n
    default_inc_excludes_dot=define
  Compiler:
    cc='cc'
    ccflags ='-DHAS_FPSETMASK -DHAS_FLOATINGPOINT_H -DNO_POSIX_2008_LOCALE -fno-strict-aliasing -pipe -fstack-protector-strong -I/usr/local/include'
    optimize='-O2 -pipe'
    cppflags='-DHAS_FPSETMASK -DHAS_FLOATINGPOINT_H -DNO_POSIX_2008_LOCALE -fno-strict-aliasing -pipe -fstack-protector-strong -I/usr/local/include'
    ccversion=''
    gccversion='FreeBSD Clang 16.0.6 (https://github.com/llvm/llvm-project.git llvmorg-16.0.6-0-g7cbf1a259152)'
    gccosandvers=''
    intsize=4
    longsize=8
    ptrsize=8
    doublesize=8
    byteorder=12345678
    doublekind=3
    d_longlong=define
    longlongsize=8
    d_longdbl=define
    longdblsize=16
    longdblkind=1
    ivtype='long'
    ivsize=8
    nvtype='double'
    nvsize=8
    Off_t='off_t'
    lseeksize=8
    alignbytes=8
    prototype=define
  Linker and Libraries:
    ld='cc'
    ldflags ='-Wl,-E  -fstack-protector-strong -L/usr/local/lib'
    libpth=/usr/lib /usr/local/lib /usr/lib/clang/16/lib
    libs=-lpthread -lgdbm -ldl -lm -lcrypt -lutil -lc
    perllibs=-lpthread -ldl -lm -lcrypt -lutil -lc
    libc=
    so=so
    useshrplib=false
    libperl=libperl.a
    gnulibc_version=''
  Dynamic Linking:
    dlsrc=dl_dlopen.xs
    dlext=so
    d_dlsymun=undef
    ccdlflags=' '
    cccdlflags='-DPIC -fPIC'
    lddlflags='-shared  -L/usr/local/lib -fstack-protector-strong'


Characteristics of this binary (from libperl): 
  Compile-time options:
    HAS_LONG_DOUBLE
    HAS_STRTOLD
    HAS_TIMES
    PERLIO_LAYERS
    PERL_COPY_ON_WRITE
    PERL_DONT_CREATE_GVSV
    PERL_HASH_FUNC_SIPHASH13
    PERL_HASH_USE_SBOX32
    PERL_OP_PARENT
    PERL_PRESERVE_IVUV
    PERL_USE_DEVEL
    PERL_USE_SAFE_PUTENV
    USE_64_BIT_ALL
    USE_64_BIT_INT
    USE_LARGE_FILES
    USE_LOCALE
    USE_LOCALE_COLLATE
    USE_LOCALE_CTYPE
    USE_LOCALE_NUMERIC
    USE_LOCALE_TIME
    USE_PERLIO
    USE_PERL_ATOF
  Built under freebsd
  Compiled at Feb 28 2024 06:43:54
  %ENV:
    PERL5LIB=""
    PERL5OPT=""
    PERL5_CPANPLUS_IS_RUNNING="5224"
    PERL5_CPAN_IS_RUNNING="5224"
    PERL5_CPAN_IS_RUNNING_IN_RECURSION="78614,5224"
    PERL_BATCH="yes"
    PERL_CANARY_STABILITY_NOPROMPT="1"
    PERL_CPAN_REPORTER_CONFIG="/var/tmp/cpansmoker-1023/2024030103/cpanreporter_000_config.ini"
    PERL_EXTUTILS_AUTOINSTALL="--defaultdeps"
    PERL_USE_UNSAFE_INC="1"
  @INC:
    /usr/perl5.39.8/lib/site_perl/5.39.8/aarch64-freebsd
    /usr/perl5.39.8/lib/site_perl/5.39.8
    /usr/perl5.39.8/lib/5.39.8/aarch64-freebsd
    /usr/perl5.39.8/lib/5.39.8
    .